top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration Why to Join

Facebook Login
Site Registration
Print Preview

Flash Player on Firefox on solaris

0 votes
87 views

I usually download the tarballs for Solaris for Firefox from the contrib directory at http://ftp.mozilla.org/

With 20.0.1 I created a plugins directory in /opt/firefox (that being where I extracted the tarball) and put a link to my flashplayer there:
libflashplayer.so -> /opt/flash/lib/libflashplayer.so

Alls well and dandy and flash player works.

I just downloaded 22.0 and did the same thing and trying streetview on google it tells me I need to get Flash Player 10 or later.

posted Jun 29, 2013 by anonymous

Share this question
Facebook Share Button Twitter Share Button Google+ Share Button LinkedIn Share Button Multiple Social Share Button

2 Answers

0 votes
 
Best answer

A truss(1) showed that SFWfirefox is now access(2)ng directories:

 $HOME/.mozilla/plugins
 /opt/sfw/lib/firefox/browser/plugins
 /usr/lib/mozilla/plugins

On a multi-user Solaris 11 system, where some users cant be trusted to never point their browser and its plugins at malware laden websites, your safest bet may be to put the libflashplayer.so plugin for Googles Streetview or Tom Kurian and companys Enterprise Manager and the libnpjp2.so for John Fowler and companys ILOM in $HOME.

answer Jun 29, 2013 by anonymous
0 votes

Try /opt/firefox/browser/plugins/ (if the plugins directory doesnt exist in /opt/firefox/browser/ just create it).

/brower/plugins/ as the only directory being checked for plugins started in 21.0. I was totally confused when I ran across the same issue in Linux, and wound up spending a bunch of time looking through the Firefox help pages trying to figure it out.

answer Jun 29, 2013 by anonymous
Similar Questions
0 votes

We need to install tomcat 7.0.68 or higher version on Sun Solaris 10. Can you let me know if there is any version compatibility matrix for Tomcat 7?

+1 vote

I tried to compile git 2.4.3 on Solaris 10. I used the following configuration:

$ ./configure --without-iconv

$ grep -i iconv config.status
ac_cs_config="'--without-iconv'"
 set X /bin/bash './configure' '--without-iconv'
$ac_configure_extra_args --no-create --no-recursion
OLD_ICONV=UnfortunatelyYes

But when I try to compile it, I get an error that libiconv is missing:

 LINK git-credential-store
Undefined first referenced
 symbol in file
libintl_gettext libgit.a(lockfile.o)
libiconv_close libgit.a(utf8.o)
libiconv_open libgit.a(utf8.o)
libintl_ngettext libgit.a(date.o)
libiconv libgit.a(utf8.o)
ld: fatal: symbol referencing errors. No output written to git-credential-store
collect2: ld returned 1 exit status
gmake: *** [git-credential-store] Error 1

How can I work around this?

+1 vote

I was installing bugzilla on Solaris machine and getting below error

./testserver.pl http://localhost
TEST-OK Webserver is running under group id in $webservergroup.
TEST-OK Got padlock picture.
TEST-FAILED Webserver is fetching rather than executing CGI files.
Check the AddHandler statement in your httpd.conf file.

I checked httpd.conf and I have added AddHandler cgi-script .cgi in this file. But not able to get through. Could you help me please.

+3 votes

I want to install git on my remote Sun sparc Solaris 10 server. Please help me with download package and installation instructions. Also help me with the dependencies.

0 votes

I'm trying to port a program that uses ptrace from linux to solaris, but no luck, as it complains that sys/ptrace.h is not found. Any idea how to port it?


Useful Links with Similar Problem
Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#470/147, 3rd Floor, 5th Main,
HSR Layout Sector 7,
Bangalore - 560102,
Karnataka INDIA.
QUERY HOME
...