top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration Why to Join

Facebook Login
Site Registration
Print Preview

Problems running emacs under Fedora-19

0 votes
37 views

When I attempt to run emacs it fails:

 $ emacs
 emacs: error while loading shared libraries: libgnutls.so.26:
 cannot open shared object file: No such file or directory
 $ rpm -q emacs
 emacs-24.2-19.fc18.x86_64

It appears that emacs hasn't been updated to the Fedora-19 libraries, which are on my computer:

 $ locate libgnutls.so
 /usr/lib/libgnutls.so.28
 /usr/lib/libgnutls.so.28.19.0
 /usr/lib64/libgnutls.so
 /usr/lib64/libgnutls.so.28
 /usr/lib64/libgnutls.so.28.19.0

libgnutls.so.26 isn't available in the standard Fedora-19 distro, nor can I find emacs-24.2-19.fc19.x86_64 .

System is Fedora-19 with all upgrades running on a 4 processor x86_64 system.

posted Jul 12, 2013 by anonymous

Share this question
Facebook Share Button Twitter Share Button Google+ Share Button LinkedIn Share Button Multiple Social Share Button
Are you sure you're fully updated?

[root@f18x ~]# rpm -q emacs
emacs-24.2-18.fc19.x86_64

yum distro-sync ??

1 Answer

0 votes

You can compile emacs just fine if you want. Follow the instructions in the INSTALL file and check the output of configure for development libraries you may want to install before compiling; they are all available from the repos.
The current version has an annoying problem with cursor placement in gnus' summary buffers, so I'm using the one that comes with Fedora.

answer Jul 13, 2013 by anonymous
Similar Questions
+2 votes

I've installed CentOS 6.4, for which Emacs 23 is available; but I'd like to have Emacs 24. I've looked at rpmforge and epel, but neither seem to have Emacs 24 already packaged; and I've searched for every combination of emacs + 24 + centos without success.

While I could, of course, just do the ./configure && make && make install dance, I don't like having software installed that's not in the packaging system. I'd appreciate any pointer to a prepackaged Emacs 24, or failing that, a good tutorial on how to package software correctly for CentOS.

+1 vote

Booted machine from livecd image, and the gnome3 worked.

Used Fedup to upgrade an Fedora 18 setup to Fedor 19, and gnome3 doesn't work (Opps screen), but KDE and Xfce does.

Did a clean install from the DVD image of Fedora 19 to a new hard disk, and gnome3 doesn't work, kde regular doesn't work, kde failsafe works, and xfce works.

The machine has a nvidia geforce FX 5200 card, which I know is old, but that is what my classroom has in all 20 machines. So, not just a matter of getting a different card. Long ago was using the nvidia driver from there site, but they dropped support for the older cards, so had to switch to the nouvea driver.

Any suggestions, or just have to stick with xfce..

+1 vote

How can I add an application launcher to the favorites menu in Fedora 19?

0 votes

It's no longer in /etc/sysconfig/iptables.

0 votes

When I installed virt-manager in Ubuntu, it created a network bridge called virbr0. Now that I have installed virt-manager in Fedora 19, it did not create a network bridge. So how do I create a network bridge? Is virt-manager supposed to create a network bridge?

I installed virt-manager using the following command.

sudo yum install virt-manager

Are there any more rpm packages which I am supposed to install?


Useful Links with Similar Problem
Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#470/147, 3rd Floor, 5th Main,
HSR Layout Sector 7,
Bangalore - 560102,
Karnataka INDIA.
QUERY HOME
...